Back to overview
Resolved
Improving the Reliability of YouTube Videos
Aug 4, 2026 at 6:00pm UTC
–
Aug 4, 2026 at 8:00pm UTC
Affected services
app.multi-upload-tool.com
api.multi-upload-tool.com
Resolved
Aug 4, 2026 at 8:00pm UTC
Maintenance ended
Affected services
Created
Aug 4, 2026 at 6:00pm UTC
We are rolling out an improvement to our upload engine to make YouTube uploads more reliable, particularly during high-volume uploads to multiple channels. This update fixes intermittent failures that occur under heavy load and optimizes the handling of retries. There may be a brief interruption in the publishing service during this operation; scheduled posts will resume automatically once maintenance is complete. No action is required on your part.
Affected services